Author Topic: Trying to update FWon my MED1000 all I get is a static 8 of blueand white blocks  (Read 4878 times)

Offline Graham N

  • Active Member
  • *
  • Posts: 50
  • Helpful Contribution Status: +0/-0

I think I posted my problem in the wrong place. Can a mod delete the one in firmware discussions please? Here is what I Posted


all of my recently added films are giving me pixellated covers and pictures. It was recommended to me to upgrade the firmware from 3.02.

All I get when I hold the power button down is the logo with the number 8 in a circle with large blue and white blocks. No countdown, no flashing light on the USB stick, it just stays there static.

When I  put the firmware on the stick do I unzip it first or will the Mede8er do it. And does it matter which USB port I plug it into. I have unzipped it first and tried both ports with the same result.

I have theMED1000X3D

EDIT Just powered down the Mede8er and tried powering up again holding button for over 10 seconds. Still the same.

EDIT 2 Solved by further searching. Had to download a program to enable me to format the USB as FAT32

thank you

« Last Edit: August 18, 2019, 01:02:53 PM by Graham N »