Author Topic: Screensaver Issues  (Read 28406 times)

Offline _Technology_

  • Active Member
  • *
  • Posts: 92
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #30 on: April 27, 2011, 09:23:42 am »
I have 4.0.4 NO_HD. Screensaver is set to on. When I pause movie it comes on and goes away with any key press. And I can keep watching from where I paused.
Have any of you tried to set it on?

I feel kind of stupid not to try this before, and yes it works fine now...I mean at least I don't have to go to main screen and all the way back to start watching movie...so thanks
Never take life seriously. Nobody gets out alive anyway.

Offline maeda

  • Newbie
  • Posts: 17
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #31 on: May 14, 2011, 02:01:52 pm »
screensaver feature is broken in 4.04, it can't be turned off, the bug is random, and is happening in media library, it doesn't happen when you are on main menu, i had to convert to 4.0.0 cause it's very annoying, please fix it in the new build.

tnx
[FW 4.0] [Samsung f3 500gb] [Samsung LE-32B551 hdmi] [Wired Lan] [x64 Win7 at 1680 x 1050]

Offline Lassy

  • Newbie
  • Posts: 5
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #32 on: May 19, 2011, 07:31:47 am »
screensaver feature is broken in 4.04, it can't be turned off, the bug is random, and is happening in media library, it doesn't happen when you are on main menu, i had to convert to 4.0.0 cause it's very annoying, please fix it in the new build.

tnx

It sure is broken. I've downgraded to 4.0.0 as well and it works fine.

Offline Harkonnen

  • Newbie
  • Posts: 13
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #33 on: May 19, 2011, 07:26:47 pm »
I am having the same problems too


but
Only after i installed a DD-WRT mod  (Tomato RAF) on my Netgear WNR3500L  router!!
Before i have NO problems.

maybe its a (linux)network or protocol issue?

it only happens after i have played a movie the screensaver comes up although i have set it to "OFF"

and it looks like this;

http://www.youtube.com/watch?v=oZt9Uq6Iqzk


 i hope this helps somewhat


Offline Harkonnen

  • Newbie
  • Posts: 13
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #34 on: May 21, 2011, 02:47:57 pm »
OK

here i am again with a step into solving this thing (i think)

 i have installed a different firmware on my router ;

DD-WRT v24-sp2 (08/12/10) mega
(SVN revision 14929)

installed the firmware
rebooted the router

turned on the mede8ter

played a movie (star trek episode)
and put it on pauze

and now i have been looking at a frozen  Geordi LaForge for over 5 minutes

the screensaver issue is gone!


so;

 i think its pretty safe to say that the cause of this screensaver error lies in the used router and (more important) firmware

maybe its handy to say which router and firmware is used by people who have this issue

i hope this helps in getting this thing resolved!!

Offline maeda

  • Newbie
  • Posts: 17
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #35 on: June 02, 2011, 03:05:43 pm »
well, firmware of any router don't have connection to the feature on mede8er such as screensaver, i don't see how it could possibly affect this
[FW 4.0] [Samsung f3 500gb] [Samsung LE-32B551 hdmi] [Wired Lan] [x64 Win7 at 1680 x 1050]

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 222
  • Helpful Contribution Status: +192/-53
Re: Screensaver Issues
« Reply #36 on: June 02, 2011, 03:36:48 pm »
Date and time tend to be part of the clock function used to control timed events in any computer. If the clock function isn't intialized properly becuase internet time isn't being communicated properly then timed events may suffer as a result.

Offline Maasbommel

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 11 503
  • Helpful Contribution Status: +51/-8
Re: Screensaver Issues
« Reply #37 on: June 02, 2011, 04:55:22 pm »
That is an interesting theory!
Read the  Mede8er 400X/500X Beginners Guide
or Mede8er 500X2/400X2/450X2 Beginners Guide

Also check the Couto X3D Newbies Guide first.

Please don't PM me but post on the forum.

Offline HHH

  • Newbie
  • Posts: 16
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #38 on: June 19, 2011, 06:41:33 pm »
Date and time tend to be part of the clock function used to control timed events in any computer. If the clock function isn't intialized properly becuase internet time isn't being communicated properly then timed events may suffer as a result.

YES!!!  :o


Just connected to the internet, did a short NetworkTimeUpdate -> Screensaver Bug is gone. Just looked about 5 minutes to the Directory listing waiting for the unwanted screensaver  :D

Restartet Med500X (Internet connection available) -> Bug is still gone  :D

Disabled the WLAN, restarted - Bug still gone  ???

Tried  another "NTP Update" failed of course, went back to the directory listing waited.... -> Bug still gone  ??? ???

Powered down the MED pulled the cord, waited 30 sek, put it in and restarted (WLAN(=NTP-Server) NOT AVAILABLE) --> Bug still gone  ??? ??? ???

This was a little bit disturbing so I read some linux man pages: Under normal circumstances the ntp deamon will try to connect to the server in hourly intervals (hopefully this is the same on mede8er) so i should get an error again in about a hour or latest tomorrow to verify this.

« Last Edit: June 19, 2011, 07:12:37 pm by HHH »

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 222
  • Helpful Contribution Status: +192/-53
Re: Screensaver Issues
« Reply #39 on: June 19, 2011, 06:52:48 pm »
From what I observed it is a "power-up" initiaisation issue. Once you have powered up with ready access to NTP, you can go back  and forth from standby to power on without access to NTP,  until the next time you fully power down. Then the clock will need "power-up initialization" again.

I was trying to fix the 20 min spurious boot up problem, not the screensaver. The screensaver may just be happy if  forced NTP update is done.

This problem appeared with V4, so V1-V3 must have done it properly.
« Last Edit: June 19, 2011, 07:10:42 pm by jer1956 »

Offline HHH

  • Newbie
  • Posts: 16
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #40 on: June 19, 2011, 07:06:45 pm »
From what I observed it is a "power-up" initiaisation issue. Once you have powered up with ready access to NTP, you can go back  and forth from standby to power on without access to NTP,  until the next time you fully power down. Then the clock will need "power-up initialization" again

Although thought of something like this and tried this too
....Powered down the MED pulled the cord, waited 30 sek, put it in and restarted (WLAN(=NTP-Server) NOT AVAILABLE) --> Bug still gone ??? ??? ???...

Seems this is not the only point. Still waiting for about half an hour to confirm my "HOUR-FREQUENCE"-theory....till then I'll have a look at Covert Affairs S01E02  ;D
« Last Edit: June 19, 2011, 07:20:19 pm by HHH »

Offline HHH

  • Newbie
  • Posts: 16
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #41 on: June 19, 2011, 07:39:44 pm »
OK, one houre ago and -without restart- screensaver bug occurs.

So the error occurs after the ntp deamon doesn not get any respond from a NTP Server this is one hour without connection to the NTP Server.


Linux man pages http://linux.die.net/man/1/ntpd:
Quote
Frequency Discipline

The ntpd behavior at startup depends on whether the frequency file, usually ntp.drift, exists. This file contains the latest estimate of clock frequency error. When the ntpd is started and the file does not exist, the ntpd enters a special mode designed to quickly adapt to the particular system clock oscillator time and frequency error. This takes approximately 15 minutes, after which the time and frequency are set to nominal values and the ntpd enters normal mode, where the time and frequency are continuously tracked relative to the server. After one hour the frequency file is created and the current frequency offset written to it. When the ntpd is started and the file does exist, the ntpd frequency is initialized from the file and enters normal mode immediately. After that the current frequency offset is written to the file at hourly intervals.

Next step: Connected WLAN, waited. After I stopped the paused movie, the screensaver disappered. I did not have to go back to the main screen.

Paused movie again, waited - >Bug is still there  ???.

Went to Settings->Time and did an NTP update , then back to the movie, paused it -> BUG STILL THERE  ??? ??? ??? ???

I don't get it.  :-[



« Last Edit: June 19, 2011, 07:56:57 pm by HHH »

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 222
  • Helpful Contribution Status: +192/-53
Re: Screensaver Issues
« Reply #42 on: June 19, 2011, 08:14:36 pm »
Just go back to making sure NTP is available when you power up.

Offline Harkonnen

  • Newbie
  • Posts: 13
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #43 on: June 25, 2011, 06:37:11 pm »
or indeed the developers should check what changed in that area of the firmware code since the last version?
since this didnt happen in previous firmwares (so i gather)

Offline maeda

  • Newbie
  • Posts: 17
  • Helpful Contribution Status: +0/-0
Re: Screensaver Issues
« Reply #44 on: July 17, 2011, 10:26:25 am »
or indeed the developers should check what changed in that area of the firmware code since the last version?
since this didnt happen in previous firmwares (so i gather)
they should, but i'm not even sure is it on the bug list, can someone confirm?
[FW 4.0] [Samsung f3 500gb] [Samsung LE-32B551 hdmi] [Wired Lan] [x64 Win7 at 1680 x 1050]