Author Topic: Mede8er MED500X2 NOT WORKING - HANGS ON SPLASH LOGO SCREEN  (Read 523 times)

Offline Akesh

  • Newbie
  • Posts: 2
  • Helpful Contribution Status: +0/-0
Mede8er MED500X2 NOT WORKING - HANGS ON SPLASH LOGO SCREEN
« on: January 19, 2018, 10:56:58 am »
Hi

I Have a Mede8er MED500X2 running the last update version V3.0.5.  Installed is a 3TB Seagate 3.5" HDD internally.  I usually use an external 2.5" portable drive with media on it which I plug in via the USB connections to watch.  All was working perfectly fine until mid December 2017, when it would not start up.  When I power the Mede8er up whether from the power button on the device or via remote controller, same results.  What I did was reinstall the version V3.0.5 firmware again using the emergency procedure, as always, and this did fix the issue and all was working great.

Early January this year, the issue returned, however, this time round I am unable to get anywhere past the Mede8er splash screen logo.  When I start up, the blue power indicator lights up on the Mede8er, then after a few seconds the power light turns off, but on the TV screen the Mede8er splash screen remains, until I force shut down the device by pulling out the power adapter.  Any help will be greatly appreciated.

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 222
  • Helpful Contribution Status: +191/-53
Re: Mede8er MED500X2 NOT WORKING - HANGS ON SPLASH LOGO SCREEN
« Reply #1 on: January 19, 2018, 11:56:35 am »
Try without the drive. The player will hang with any power up overload issue. And there is evidence that the players suffer from aging power circuits. Inbuilt redundancy by building down to a price.

Offline Akesh

  • Newbie
  • Posts: 2
  • Helpful Contribution Status: +0/-0
Re: Mede8er MED500X2 NOT WORKING - HANGS ON SPLASH LOGO SCREEN
« Reply #2 on: June 06, 2018, 11:42:33 am »
Hi jer1956, thanks for the response.  Only checked back now, thought I would have gotten an email notification that a reply was made to my post. I did try unplugging the internal HDD, no media drive was plugged in at all (internal or external), and still the same thing, hangs on splash screen.

Any other solutions?  would really appreciate it.

I was thinking of trying this : get the bootloader installation files, install that, if that works, then try installing the firmware update.  tried whatever I could, this is the last option I can think of trying.

Been using the built-in media player on the Samsung 3D Blu-Ray Player (BD-J7500/XA) till I can get the Mede8er (hopefully) working again, and its not the same, you don't get the options you would with the Mede8er, and honestly it [CENSORED].

If all else fails, could mean I would have to retire the Mede8er :( and if so, I would like to try an alternate, seeing as how Mede8er is no longer available, any suggestions on that?  Would have thought Mede8er would have brought out their newer version like a Smart Mede8er or something.