Author Topic: should I be expecting this ? SMB_VERSION is SMB_1  (Read 305 times)

Offline leeincm

  • Newbie
  • Posts: 30
  • Helpful Contribution Status: +0/-3
should I be expecting this ? SMB_VERSION is SMB_1
« on: July 22, 2017, 06:20:20 am »
I typed this command on my Mac:

smbutil statshares -a

and it says:
                             SMB_NEGOTIATE SMBV_NEG_SMB1_ENABLED
                             SMB_NEGOTIATE                 SMBV_NEG_SMB2_ENABLED
                             SMB_NEGOTIATE                SMBV_NEG_SMB3_ENABLED
                             SMB_VERSION                   SMB_1
                             SMB_SHARE_TYPE                UNKNOWN
                             EXTENDED_SECURITY_SUPPORTED   TRUE
                             UNIX_SUPPORT                  TRUE
                             LARGE_FILE_SUPPORTED          TRUE

Does that mean my med and mac are using SMB_1 to communicate? Is this to be expected? I looked on samba.org site and it seems they are up to SMB 4.7 or something now  :-[

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 019
  • Helpful Contribution Status: +184/-37
Re: should I be expecting this ? SMB_VERSION is SMB_1
« Reply #1 on: July 22, 2017, 07:45:00 am »
Yes
The player only supports SMB 1

Offline TifKag

  • X2 Skin Designer
  • Active Member
  • ***
  • Posts: 99
  • Helpful Contribution Status: +4/-13
Re: should I be expecting this ? SMB_VERSION is SMB_1
« Reply #2 on: July 22, 2017, 08:11:13 am »
I typed this command on my Mac:

smbutil statshares -a

and it says:
                             SMB_NEGOTIATE SMBV_NEG_SMB1_ENABLED
                             SMB_NEGOTIATE                 SMBV_NEG_SMB2_ENABLED
                             SMB_NEGOTIATE                SMBV_NEG_SMB3_ENABLED
                             SMB_VERSION                   SMB_1
                             SMB_SHARE_TYPE                UNKNOWN
                             EXTENDED_SECURITY_SUPPORTED   TRUE
                             UNIX_SUPPORT                  TRUE
                             LARGE_FILE_SUPPORTED          TRUE

Does that mean my med and mac are using SMB_1 to communicate? Is this to be expected? I looked on samba.org site and it seems they are up to SMB 4.7 or something now  :-[

You should not ask yourself, what version samba is on NOW, but what version samba was on when the hardware for the mede8er was developed !!!!!!!

BUT by only supporting V!, the mede8er is always compatible with older Hardware like older Macs, older Windows PC's and especially older versions NAS devices !!!!!

Don't get me wrong, i know the Mede8er has it's flaws, but untill now it still does everything i need it to do.(Although i think Sanji can not exist only on the selling of these older models, and have to come up with a new player soon that adds 4K and HDR to the allready existing features, because they are losing the battle of keeping up with modern technology).

But i am not bashing Mede8er in every message i post (Like you are trying to do).

 
« Last Edit: July 22, 2017, 08:51:10 am by TifKag »

Offline leeincm

  • Newbie
  • Posts: 30
  • Helpful Contribution Status: +0/-3
Re: should I be expecting this ? SMB_VERSION is SMB_1
« Reply #3 on: July 22, 2017, 03:32:09 pm »
Why have u completely rewritten your reply?

In your first reply you criticized mede8er for only supporting SMB v1 at the time the Med1000 was launched (2012/13?)

But now you are praising mede8er for only supporting SMB 1 ... lol .. and very very strange

Why the 24 hour U-turn ?

What would have been wrong with mede8er supporting SMB 1 and SMB 2 in 2012 ?

Care to re-share your original reply before you completely changed its meaning ?

And btw, I am not trying to "But i am not bashing Mede8er in every message i post (Like you are trying to do)." - I am simply asking why a modern device only supports SMB_1 ... not a valid question to ask?


You should not ask yourself, what version samba is on NOW, but what version samba was on when the hardware for the mede8er was developed !!!!!!!

BUT by only supporting V!, the mede8er is always compatible with older Hardware like older Macs, older Windows PC's and especially older versions NAS devices !!!!!

Don't get me wrong, i know the Mede8er has it's flaws, but untill now it still does everything i need it to do.(Although i think Sanji can not exist only on the selling of these older models, and have to come up with a new player soon that adds 4K and HDR to the allready existing features, because they are losing the battle of keeping up with modern technology).

But i am not bashing Mede8er in every message i post (Like you are trying to do).

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 019
  • Helpful Contribution Status: +184/-37
Re: should I be expecting this ? SMB_VERSION is SMB_1
« Reply #4 on: July 22, 2017, 04:09:41 pm »
Lets not find anger when none is implied. A simple question was asked, and answered. The 1186 SDK was little changed from the much older 1073. It was stuck in the past in more way than one.
But it did mean code could be ported from 1073 to 1185, then 1186.