Author Topic: 500x2 scraper app not working  (Read 1395 times)

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
500x2 scraper app not working
« on: July 17, 2017, 08:48:50 am »
The internal scraper app on my 500X@ was working perfectly and now it suddenly does not work.

If I try to edit the default about page for the movie and click "scrape", it just goes to endless rotating circle!

I have internet access and Google loads from my Mede8er.

I have reinstalled the firmware and rebooted my whole network many times and still it does not work!

Help!!

Edit: I have now managed to get it to crawl along!

I'm not sure why it is now working, albeit extremely slowly! It may be that I changed the Wifi DNS to 8.8.8.8.

It takes about 20 mins per title or longer and the app doesn't like to get fanart! Most of the movies I have scraped now don't have fanart.

I have checked themoviedb and the movies do have fanart (they call them "backdrops")

Any suggestions anyone?
« Last Edit: July 17, 2017, 12:33:27 pm by Ahari »
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
Re: 500x2 scraper app not working
« Reply #1 on: July 18, 2017, 07:45:17 am »
I have discovered that the cause of the scraper app seemingly freezing is if the movie does not have "English" tag on the backdrop in themoviedb.

Does anyone know of a fix for this?

The scraper app should find all languages or no language tagged backdrops.

Is there a setting or workaround for this issue?
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
Re: 500x2 scraper app not working
« Reply #2 on: July 18, 2017, 04:35:23 pm »
I am no expert, but it would appear that something has changed with the way themoviedb handles search queries from the built in scraper. This is causing the Mede8er scraper to insist on only retrieving backdrops with an "English" tag. Since most of the backdrops on themoviedb do not have a language tag, the scraper endlessly waits for an english tagged backdrop.

It would appear to be a simple fix for someone who can update the firmware to correct the search strings to themoviedb to include backdrops that have no language tag. It would appear that the simple inclusion of ",null" at the end of whatever search string the scraper sends to themoviedb will fix this - I will leave that to the experts!! https://developers.themoviedb.org/3/getting-started/image-languages

Some sort of a timeout if no image is found would also be nice :)

It would appear from searching the forum that this issue is also affecting the newer Mede8ers.

I only hope someone can fix this!!
« Last Edit: July 18, 2017, 04:44:48 pm by Ahari »
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA

Offline soedemaker

  • Newbie
  • Posts: 1
  • Helpful Contribution Status: +0/-0
Re: 500x2 scraper app not working
« Reply #3 on: July 27, 2017, 03:48:36 pm »
I think this is related to the SSL handshake failed error, due to that mede8er not being able to handle the most recent developments in internet browsing.
I can not use internet (Youtube etc.) and get this error. It would be nice and also customer friendly if Mede8er could provide with some solution. I just sent a message with this request, hopefully will get at least some response.

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
Re: 500x2 scraper app not working
« Reply #4 on: July 28, 2017, 09:28:49 am »
I think it has to do with thetvdb and themoviedb updating their scrapers and retiring the old ones that Mede8er were set up to use.

Unless Mede8er update the firmware to allow the use of the new apps, the scraping function will die!

That will mean Mede8er will die too... sad :(

I have given up hope for my Mede8er ever being able to scrape again as it doesn't seem like Mede8er are going to update the firmware... ever!

It seems that it is only a matter of time before Thumbgen and TVRename also die.

That means that the only way to scrape will be manually!

I am probably going to stop loading new stuff to my Mede8er and only use it for the stuff I have already got.

I'm looking into setting up an old PC with UnRaid, Kodi and Plex to replace the Mede8er for good.

No-one seems to care about the newer models let alone the older ones any more and lets face it, the Mede8er was always a major pain to get it to work as it should!!

Mede8er is dead. It was good while it lasted and I'm very sad  :-[
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 231
  • Helpful Contribution Status: +193/-54
Re: 500x2 scraper app not working
« Reply #5 on: July 28, 2017, 09:33:11 am »
Some of the external scrapers work by converting the output of third party scrapers. They should be upgrading theirs to match....if there is demand from their core users.

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
Re: 500x2 scraper app not working
« Reply #6 on: July 28, 2017, 09:36:37 am »
What scraper do you recommend? I'll try anything to keep my player working, but I have just about given up...
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 231
  • Helpful Contribution Status: +193/-54
Re: 500x2 scraper app not working
« Reply #7 on: July 28, 2017, 09:42:44 am »
No one has started posting issues about them, but i fear it's because everyone has stopped using Med's and their scrapers in favour of Kodi. The Yadis code looks stuck in 2015, and no longer upgraded. 

Yadis was created for dune players, a bigger market than mede8er. So it likely to still get upgraded if asked.

http://www.mede8erforum.com/index.php/board,144.0.html
« Last Edit: July 28, 2017, 09:52:36 am by jer1956 »

Offline Ahari

  • Experienced Member
  • **
  • Posts: 110
  • Helpful Contribution Status: +2/-0
Re: 500x2 scraper app not working
« Reply #8 on: July 29, 2017, 06:12:03 pm »
Thanks jer1956!

It is getting very quiet around here... Listen, I can hear crickets chirping!!

Will the last person to leave, please turn out the lights!
MED500X2 with 2Tb drive - F/W V3.0.5_23April2015_BETA