Author Topic: Edit Rating  (Read 6662 times)

Offline Magmastern

  • Newbie
  • Posts: 1
  • Helpful Contribution Status: +0/-0
Edit Rating
« on: January 05, 2016, 11:03:26 am »
Hi community,

I'm very satisfied with the YamJ to Mede8er tool but i have problems to place the correct rating information to some movies (-0.1/10 problem). I created .nfo files, edited the rating line - but after the "Run YAMJ" process i get incorrect rating values (just about the half).
I read in the YAMJ community that this problem was fixed with the current YAMJ release (2.10) but with the MEDE8ER we can only use release 2.05.
Any idea to insert the correct rating?

Thank's for your support!
Marcus

Offline ibanez-29

  • Newbie
  • Posts: 15
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #1 on: February 03, 2016, 04:42:05 am »
im experiencing the same issue

(-0.1/10 problem)

Offline Treken

  • Newbie
  • Posts: 9
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #2 on: February 12, 2016, 07:01:01 pm »
Same (-0.1/10 problem) here for 3-4 weeks now. Nothing on computer has been installed since it was working...

If others has this problem, a solution to this would be nice to see...

Offline mtrupinic

  • Newbie
  • Posts: 7
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #3 on: February 13, 2016, 01:20:14 pm »
i have same problem...

(-0.1/10 problem)

Offline Lancito

  • Newbie
  • Posts: 22
  • Helpful Contribution Status: +0/-3
Re: Edit Rating
« Reply #4 on: February 15, 2016, 03:35:16 am »
Same here.  Gettting (-0.1-10) rating.

It is high time for YAMJ for Mede8er to get updated.  It is already 4 years old.

Offline Treken

  • Newbie
  • Posts: 9
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #5 on: February 23, 2016, 12:17:15 am »
There must be others getting this too... Nothing to do with java... I think, it has to do with the new format of IMDB...That is when I got the -0.1/10 problem...

Offline sphinc70

  • Newbie
  • Posts: 11
  • Helpful Contribution Status: +2/-0
Re: Edit Rating
« Reply #6 on: February 23, 2016, 08:25:19 am »
Hi Everyone,
I am having the exact same problem. The issue started about a month ago. After some trial and error, I do have a 'solution' of sorts. It does involve manually editing every movie scraped by Y2M with XML notepad. The procedure I adopt is as follows:
1. Once the movie is scraped by Y2M go to the jukebox and locate the XML file for the movie that you want to edit.
2. Right click on the file and choose 'edit with XML notepad'. I am using windows 7 64 bit.
3. Expand the movie folder. You will see an icon named 'rating'. Open that file and you will see the offending -1.
4. Highlight the entry then change the rating to the rating given on the IMDB website. The rating must be entered as a figure out of 100 ie if IMBD has a rating of 6.7, the the number 67 must be entered.
5. Under the rating icon, you will see another heading called 'ratings'. Repeat the exact same procedure as above. Once these two figures have been adjust, save the file.
6.Re-run Y2M and the correct rating will now appear.

You only have to edit the file in the jukebox as the file in the movie folder will automatically be updated when Y2M is re-ran.

This seems like a lot of work, but in reality it only takes me a minute or so to complete which is fine for me as I only add a few movies a week to my collection. I have had 100% success with this method. If anyone has another method, I'm all ears, but at this point I have not found an easier way to correct this issue.

I hope that I have explained this well enough and that it provides some assistance.

Regards
Sphinc70

Offline gmusteric

  • Newbie
  • Posts: 2
  • Helpful Contribution Status: +1/-0
Re: Edit Rating
« Reply #7 on: March 01, 2016, 10:02:24 pm »
In YAMJ settings, under IMdB, set full.info to TRUE.
Then scan and rating will be as on IMdB.

Offline OldskoolOrion

  • Newbie
  • Posts: 25
  • Helpful Contribution Status: +7/-0
  • I like Pi !
Re: Edit Rating
« Reply #8 on: March 01, 2016, 11:26:20 pm »
Correct, but doesn't ALWAYS fix this issue : wouldn't be the first time if some setting got corrupted.


So also check your settings : many people have (even when thinking it gets scraped off IMDB) the following setting :


mjb.rating.source = average

with api's changing, thus plugins not working suddenly, "average" is not the setting you want.
Make it foolproof by setting it to :


mjb.rating.source = imdb, rottentomatoes, average

This will make sure, that first IMDB is tried as a source for rating. If that fails, rottentomatoes is used as backup.. and if that ALSO fails.. only then, are other plugins/sites used to come up with an average rating.


Maybe even leave "average" out, if one plugin fails or a website is down, or an api is changed, the average of all the other ratings, might not be what you expect & seek.

Alphamale on betablockers !

Offline Treken

  • Newbie
  • Posts: 9
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #9 on: March 02, 2016, 01:57:46 pm »
Correct, but doesn't ALWAYS fix this issue : wouldn't be the first time if some setting got corrupted.


So also check your settings : many people have (even when thinking it gets scraped off IMDB) the following setting :


mjb.rating.source = average

with api's changing, thus plugins not working suddenly, "average" is not the setting you want.
Make it foolproof by setting it to :


mjb.rating.source = imdb, rottentomatoes, average

This will make sure, that first IMDB is tried as a source for rating. If that fails, rottentomatoes is used as backup.. and if that ALSO fails.. only then, are other plugins/sites used to come up with an average rating.


Maybe even leave "average" out, if one plugin fails or a website is down, or an api is changed, the average of all the other ratings, might not be what you expect & seek.

I tried but does not work to get rating back...

Offline Buff

  • Newbie
  • Posts: 5
  • Helpful Contribution Status: +1/-0
Re: Edit Rating
« Reply #10 on: March 15, 2016, 05:13:42 am »
The above method is working, so do the above close the app go to YAMJ folder where it keeps all the cache delete everything in the folder.

Start the app, it will get the ratings.

good luck.

Offline Treken

  • Newbie
  • Posts: 9
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #11 on: March 27, 2016, 05:03:58 am »
It's been close to 2 weeks and still no solution from what others said to try and failed to fix...

I am still hoping that there will be a solution to this, as others are as well...

Offline Ronaldk

  • X3D Skin Designer
  • Experienced Member
  • ***
  • Posts: 110
  • Helpful Contribution Status: +7/-1
Re: Edit Rating
« Reply #12 on: March 27, 2016, 07:23:19 pm »
@ Treken

I have applied both the proposals from OldSkoolOrion and Gmusteric and it worked for me. I am happy with there solutions and salute them! Thanks guys.
Mede8ers: MED600x3D, MED450X2, MED500X
Amplifier: Pioneer SC-LX57
TVs: LG 55LA6210, Samsung UA40EH5300, Sony 46"
Network devices: Netgear gigabit switches, WD MyBookLive, Windows 8.1 PC with drive bender for file serving via Samba.

Offline fatalivee

  • Newbie
  • Posts: 1
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #13 on: March 28, 2016, 08:01:29 am »
finally its work,,,thanks for sharing guys,,#thumbs up for gmusteric, OldskoolOrion n buff

« Last Edit: March 28, 2016, 12:12:21 pm by fatalivee »

Offline Treken

  • Newbie
  • Posts: 9
  • Helpful Contribution Status: +0/-0
Re: Edit Rating
« Reply #14 on: April 07, 2016, 09:03:54 pm »
Thank you very much OldSkoolOrion and Gmusteric...

After applying both and deleting everything from Jukebox folder it is finally working again...