Author Topic: Apostrophe in XML file shows like this: '  (Read 5277 times)

Offline mikek

  • Newbie
  • Posts: 36
  • Helpful Contribution Status: +0/-1
Apostrophe in XML file shows like this: '
« on: March 22, 2015, 12:55:15 pm »
This: ' shows up instead of an apostrophe when using Y2M.

Does anybody know how to fix it?  I can fix it manually in the xml file, but I am looking for a permanent fix.

Offline herosenju

  • Newbie
  • Posts: 2
  • Helpful Contribution Status: +0/-2
Re: Apostrophe in XML file shows like this: '
« Reply #1 on: March 24, 2015, 03:16:00 am »
I reused in everyday life.

Offline OldskoolOrion

  • Newbie
  • Posts: 25
  • Helpful Contribution Status: +7/-0
  • I like Pi !
Re: Apostrophe in XML file shows like this: '
« Reply #2 on: March 01, 2016, 11:35:11 pm »
Suddenly out of the blue had the same - besides annoying it was not a big issue for me, because using sed a search and replace in xml files is fast and easy.


What fixes it was deleting the registry settings and go back to the original setting/properties files (basically clean unpack). That was also annoying because I had to do all my little tweaks, additions, alterations etc. again. (thanked myself for filebased compare from a recent backup of the directory - i usually skip backups).


So running a batch file with a search&replace freeware tool under windows or 'sed' under unix/linux after scrapping, might be just as good as a solution.


Do an extra search on &#x after replaces the x27 with an '  : not all, but many characters with accents were actually affected, when I had that problem.



Alphamale on betablockers !

Offline mikek

  • Newbie
  • Posts: 36
  • Helpful Contribution Status: +0/-1
Re: Apostrophe in XML file shows like this: '
« Reply #3 on: May 29, 2016, 10:29:09 pm »
I never have fixed this problem. Where do I delete the registry settings you refer to?

Offline mikek

  • Newbie
  • Posts: 36
  • Helpful Contribution Status: +0/-1
Re: Apostrophe in XML file shows like this: '
« Reply #4 on: June 03, 2016, 02:50:53 am »
I noticed if I change IMDb full.info to TRUE (which actually gives the short descriptions) that is where it won't display the apostrophe correctly.

When I change it to FALSE (default) that is where ' appears instead of apostrophe.