Mede8er Forum

Mede8er Products => MED600X3D / MED1000X3D / MED800X3D => Technical Issues => : Spike30 April 06, 2019, 07:40:58 PM

: Trailers stopped working
: Spike30 April 06, 2019, 07:40:58 PM
Hello

I hope somebody can help me, I scanned my favorite map of movies to add the trailers, on the screen of the movie there's is a "T"button for the trailer when i open it i only get a screen with a sofa! thank a lot
: Re: Trailers stopped working
: jer1956 April 14, 2019, 08:50:27 AM
I have PM'd the user.

The server provider changed the PHP support..yet again.

I have got VideosearchXL working.  Pleas check trailers.
: Re: Trailers stopped working
: kazza61 May 13, 2019, 08:33:46 PM
Same issue for me. Would appreciate help on how to switch to VideosearchXL if that is the recommended solution.
Many thanks.
: Re: Trailers stopped working
: jer1956 May 14, 2019, 12:49:59 PM
VideoseachXL is a Youtube replacement. It gets its videos  from the same 3rd party video server as trailers.  So if VideosearchXL is fixed when trailers stop....it means trailers should be fixed as well.
: Re: Trailers stopped working
: kazza61 May 14, 2019, 05:00:15 PM
Thanks for the reply jer1956. Is this something we need to do in the Mede8er settings?
: Re: Trailers stopped working
: kazza61 May 14, 2019, 06:48:42 PM
Actually, seems to be working again so all good. If something has happened behind the scenes, then many thanks!
: Re: Trailers stopped working
: kazza61 July 11, 2019, 05:55:36 PM
No trailers seem to be working at the moment. Any advice anyone? Thanks.
: Re: Trailers stopped working
: jer1956 July 12, 2019, 10:03:45 AM
I have checked using edge F12, and the code is getting a 403 error....request to server is acknowledged but  rejected.
I forwarded this to YTAPI.
Google/Youtube may have finally blocked third party access that bypasses their DRM.
: Re: Trailers stopped working
: kazza61 July 12, 2019, 05:47:15 PM
Thanks for looking into it. Would be lovely if it could be sorted but appreciate how things move on.
: Re: Trailers stopped working
: jer1956 July 13, 2019, 07:16:36 AM
We make an explcit request for HD720p video. That is the part thats failing. Without that request the command works....but we only get 320P rubbish instead.
YTAPI are looking into it.

It may also explain VideosearchXL failing so often. At the moment it fails all the time due to the 720P issue.
There is no fall back mechanism in the YTAPI code. If we request 720P, we get 720P, or nothing.

I have modified the VideosearchXL code, so its working in the 320P mode for now.
: Re: Trailers stopped working
: kazza61 July 13, 2019, 08:44:26 PM
Jer1956 you have delivered magic yet again! Thanks for sorting this - it's really appreciated.
: Re: Trailers stopped working
: jer1956 July 14, 2019, 12:23:43 PM
The videos are stuck on 320P at the moment. YTAPI are trying to get 720P back.

This is the player we are using.

http://www.s.ytapi.com/CustomPlayerDemo/

Yesterday they got the vq=720 command working again, but at the default.  If you test all three quality options, they  are all the default.

: Re: Trailers stopped working
: jer1956 July 15, 2019, 08:01:32 PM
YTapi have looked at youtube have changed.  In order to  give the player a DRM free stream, it must be downloaded in chunks, the chunks get drm removed, and then sent out to the player that requested that stream.
Youtube are no longer making HD available as a download.  So the requests have been rejected.

All they can do is request crap SD, and ignore the vq command we have been sending. 
: Re: Trailers stopped working
: kazza61 July 15, 2019, 08:25:15 PM
Would prefer HD but to be honest I can live with the SD. As long as there is something that gives a flavour of the movie I'm fine. I've got do many movies on my player that I often forget even the gist of it. An SD trailer serves it purpose for me.
Thanks again for looking into this.
: Re: Trailers stopped working
: t-force August 18, 2019, 08:15:13 AM
So are we able to view SD trailers? What do we need to do to make this possible?